🍞 A retro dark theme for Hugo https://after-dark.habd.as
You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 

49 lines
2.1 KiB

{
"name": "after-dark",
"version": "6.12.6",
"description": "A deceptively simple dark theme for Hugo.",
"author": "Josh Habdas <jhabdas@protonmail.com>",
"keywords": [
"hugo",
"hackcss",
"lazysizes",
"lodash",
"vue",
"fuse.js",
"mark.js"
],
"homepage": "https://after-dark.habd.as",
"repository": {
"type": "git",
"url": "https://git.habd.as/comfusion/after-dark.git"
},
"standard-version": {
"scripts": {
"posttag": "git tag --sign $(git describe --tags $(git rev-list --tags --max-count=1)) $(git describe --tags $(git rev-list --tags --max-count=1))^{} -f -m \"$(git log -1 --pretty=%B)\" -m \"-----BEGIN DIST INTEGRITY-----\" -m \"$(npm pack --dry-run --json . | grep integrity | cut -d ',' -f1 | cut -d ':' -f2 | tr -d '\" ')\" -m \"-----END DIST INTEGRITY-----\""
}
},
"scripts": {
"update:lazysizes": "npm up lazysizes && cp -i node_modules/lazysizes/lazysizes.min.js static/js",
"update:lodash:custom": "./node_modules/.bin/lodash include=debounce -p -o static/js/lodash.custom.min.js",
"update:smoothscroll": "npm up smoothscroll && cp -i node_modules/smoothscroll-polyfill/dist/smoothscroll.js static/js",
"update:fuse": "npm up fuse.js && cp -i node_modules/fuse.js/dist/fuse.min.js static/js",
"update:vue": "npm up vue && cp -i node_modules/vue/dist/vue.min.js static/js",
"update:mark": "npm up mark.js && cp -i node_modules/mark.js/dist/mark.min.js static/js",
"update:hackcss": "npm up hackcss && cp -ir node_modules/hack/dist/ assets/css/vendor/hack/",
"test": "while true; do head -n 100 /dev/urandom; sleep 0.1; done | hexdump -C | grep 'ca fe'",
"integrity": "npm pack --dry-run --json . | grep integrity | cut -d ',' -f1 | cut -d ':' -f2 | tr -d '\" '",
"release": "standard-version"
},
"devDependencies": {
"atom-one-chroma": "^2.0.0",
"fuse.js": "^3.2.1",
"hack": "^0.8.1",
"lazysizes": "^4.0.4",
"mark.js": "^8.11.1",
"smoothscroll-polyfill": "^0.4.3",
"vue": "^2.5.16",
"lodash-cli": "^4.17.5",
"standard-version": "^4.4.0"
},
"license": "WTFPL"
}